Back to overview
Scheduled network maintenance on API
May 12, 2026 at 9:00am UTC
Affected services
mybooks.chat
Resolved
May 12, 2026 at 9:00am UTC
API and all backend services offline for an hour
Affected services
Resolved
May 12, 2026 at 9:00am UTC
API and all backend services offline for an hour
Affected services